ESXi 4.x Installable HP Customized ISO Image DNA

October 12th, 2010 by jason Leave a reply »

Those of you who are deploying ESXi in your environment probably know by now there are a few different flavors of the installable version you can deploy from:

  • ESXi 4.x Installable (the non-hardware-vendor-specific “vanilla” ESXi bits)
  • ESXi 4.x Installable Customized ISO Image (hardware-vendor-specific bits)
    • ESXi 4.x Installable HP Customized ISO Image
    • ESXi 4.x with IBM Customization
    • ESXi 4.x Installable Dell Customized ISO Image

Each of the major hardware manufacturers does things a little differently with respect to what and how they bake in their special components into ESXi.  There doesn’t seem to be much of a standard which the vendors are following.  The resulting .ISO file naming convention varies between vendors and even between builds from a specific vendor.  The lack of standards here can make managing a library of ESXi releases among a sea of datacenter hardware difficult to to keep track of.  It seems a bit careless if you ask me, but there are bigger fish to fry.

This short post focuses specifically the HP flavor of ESXi.  What’s the difference between ESXi 4.x Installable and ESXi 4.x Installable HP Customized ISO Image?  The answer is the HP ESXi Offline Bundle.  Essentially what this means is that if you install ESXi 4.x Installable, then install the HP ESXi Offline Bundle, the sum of what you end up with is identically equivalent to installing the ESXi 4.x Installable HP Customized ISO Image.

In mathematical terms…

SnagIt Capture

Where are these HP ESXi Offline Bundles?  You can grab them from HP’s web site.  Thus far, HP has been producing an updated version for each release of vSphere.  For reader convenience, I’ve linked a few of the most recent and relevant versions below:

In addition to the above, both ESX 4.1 and ESXi 4.1 on HP systems requires an add-on NMI Sourcing Driver which is discussed here and can be downloaded hereFailure to install this driver might result in silent data corruption. Isn’t that special.

Advertisement

5 comments

  1. gogogo5 says:

    In our lab, we installed ESXi 4.1 “vanilla” on a set of HP BL460c G6 blades then we installed the HP ESXi Offline Bundle for VMware ESXi 4.1 via vMA.

    Then we found that after “an amount of time” if you go to the Hardware Status tab of your ESXi host you’ll find the “Updating hardware data” timeout with the following error:

    “Hardware monitoring service on this host is not responding or not available” Great!

    Uninstall the bundle and voila, the base set of sensors are returned.

    FYI – when you install the HP Offline bundle you will see 3 additional sensors listed on the Hardware Status tab: Battery, Storage & Baseboard Management Controller.

    We spoke with HP and they said, oh, wait until the next version coming out soon.

    Moral of the story – don’t bother with the HP baked ISO, stick with the vanilla VMware ISO and control what bundles go on (ones that work!).

    -gogogo5

  2. AC says:

    Some things that might be good to know in addition to what was posted:

    * HP’s current CIM providers do not work with VUM. You can find all sorts of details at http://tinyurl.com/3ae8wx6. Rumor has it the next version is going to fix this and that it is going to be released soon.

    * HP recently (Oct. 4) released version 1.1 of the NMI driver. Version 1.0 does not work properly in VUM. Unlike the CIM providers, you can upload it to VUM just fine, but even though the description says it works for ESX/ESXi 4.1, it really only works on ESX classic. VUM thinks it is not applicable to ESXi 4.1. I’ve tested 1.1, however, and it works great with VUM now.

    I’ve also heard that HP has included some custom drivers in their version of the CD that aren’t included with the vanilla CD from VMware. I think it only applies to certain server models, however.

  3. AC says:

    Sorry, I should’ve been more clear on that first bullet point. Version 1.0 of the HP CIM providers for ESXi 4.1 is the version that does not work correctly. “Current” probably won’t be a good descriptor in a few weeks. And yeah, what’s with the versioning? The nice thing is that if you were running, say, version 1.3 of the CIM providers on ESXi 4.0 and then you upgrade to ESXi 4.1 and HP CIM 1.0, then look at your installed packages, it still shows version 1.3 and 1.0 as being installed. Just a bit confusing considering 1.0 is the more recent one. Hopefully when they fix the issue with importing into VUM they will also fix the issue of not removing the previous version properly…

Leave a Reply